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1 Introduction
This guide explains how to use FaderMate with Cockos Reaper.

It was prepared with reference to Reaper version 5.77 running on Microsoft Windows 10.

Some details may vary slightly depending upon the versions of Reaper and Windows you 

are running.

NOTE: This document is not an exhaustive product guide for Reaper. If you need 

more in-depth information about operating the software, please refer to 

https://www.reaper.fm/userguide.php.   

2 Before You Begin
Before starting the setup process, please ensure that you have:

• Connected your MIDI interface to the computer correctly

• Connected the FaderMate MCU to the MIDI interface as outlined in the Product 

Manual. This can be downloaded from http://fadermate.co.uk/downloads.html

• The HUI full scale settings for all FCUs in their default configuration

http://fadermate.co.uk/downloads.html
https://www.reaper.fm/userguide.php


3 Basic Setup
It is first necessary to configure the FCUs in your FaderMate installation as HUI banks in 

Reaper.

Select the menu item Options > Preferences. 

You will see the Preferences window. Select the option Control/OSC/web in the left-hand 

pane as shown in Figure 3.1

Figure 3.1 – Control Surface Options

NOTE: Repeat the following steps once for each FCU you would like to connect.

Click Add. 

You will see the Control Surface Settings window. Click the dropdown menu and select the

option HUI (partial) as shown in Figure 3.2.



Figure 3.2 –  Adding a HUI Device

Figure 3.3 shows the MIDI input dropdown. Select the MIDI input which is connected to the

FCU bank you are configuring.

Figure 3.3 – MIDI Input Selection

Select the MIDI output in a similar way using the MIDI output dropdown.



Now set the Surface offset parameter (shown in Figure 3.4) appropriately. 

Figure 3.4 – ‘Surface offset’ Parameter Entry

If you wish to control Reaper’s master volume with the first fader on your console, this 

parameter should be set to 0, 8, 16 or 24 for FCUs 1 to 4 respectively. 

If you only want to interact with track volumes (the most likely case), Surface offset should 

be set to 1, 9, 17 or 25 for FCUs 1 to 4 respectively.

The Fader count parameter should be left as the default value (8).

Figure 3.5 shows the Control Surface Settings window after the following settings have 

been entered:

• FCU index: 1 (first 8 faders)

• MIDI input: M-AUDIO MIDISPORT 4x4 (Input 1)

• MIDI output: M-AUDIO MIDISPORT 4x4 (Output 1)

• First fader: Controls first track (not master)



Figure 3.5 – Control Surface Settings For FCU 1

Press OK to accept your settings (indicated in Figure 3.5).

You will now be returned to the Preferences window with the Control/OSC/web option still 

selected. You should see an entry in the Control surfaces/OSC/web control pane for every 

HUI instance which has been configured so far.

For example, after configuring FCUs 1, 2 and 3, the Preferences window will look 

something like Figure 3.6.

Figure 3.6 – Control Surface Preferences With 3 FCUs Configured



Press OK.

You can verify that FaderMate and Reaper are talking to each other by adding tracks to a 

Reaper project and performing the following tests:

• Move track faders on Reaper’s Mixer and verify that the corresponding physical 

faders on your console move in a similar way (proves that Reaper can transmit 

MIDI data to FaderMate)

• Move physical faders on your console and verify that the corresponding track faders

on Reaper’s Mixer move in a similar way (proves that FaderMate can transmit MIDI 

data to Reaper)



4 Volume Envelope Settings

4.1 Background
FaderMate interacts with track volumes. 

That is, in general, when a physical fader is moved downwards, a Reaper track volume is 

reduced. Correspondingly, when a Reaper track volume is reduced, a physical fader 

moves downwards.

Therefore, whether FaderMate is being used as a control surface or as an analogue 

moving fader system, the automation data will be stored in the volume envelopes 

associated with some tracks in a Reaper project.

In order to achieve the desired behaviour, it is necessary to adjust some of the default 

settings for volume envelope behaviour.

4.2 Envelope Range
By default, Reaper’s track volume envelopes have a range from -inf to +6dB. However, the

default volume range of Reaper’s faders is -inf to +12dB. 

This means that although your FaderMate system will move Reaper’s faders through their 

full range of movement (and vice-versa), any volume envelopes you record will be clipped 

at +6dB. If you played such an envelope back, you would notice that your physical faders 

never ‘reached the top’.

To remedy this, it is necessary to modify Reaper’s volume envelope settings.

The volume envelope settings can be found in the Editing > Envelope Display pane of 

the Preferences window as shown in Figure 4.2.1.



Figure 4.2.1 – Modifying Volume Envelope Settings

Change the Volume envelope range setting to “-inf..+12dB” using the dropdown indicated 

by the arrow in Figure 4.2.1.

Press OK to accept the change.

NOTE: The “Volume envelope range” parameter is global, i.e. it applies to all tracks 

in the project.

4.3 Envelope Scaling
By default, Reaper’s track volume envelopes are scaled according to amplitude. At the 

bottom end of the envelope’s range, a small distance on the screen corresponds to a large

change of gain in dB (which in turn causes a large fader move).

Under normal circumstances, to make the moving faders behave as expected, it is 

necessary to make the track volume envelopes map geometrically to the travel of the 

physical faders. 

That is, if you manually draw an envelope point which looks roughly a quarter of the way 

from the bottom, you can expect the physical fader on the console to be a quarter of the 

way from the bottom of its travel too.



To set a track volume envelope to the appropriate mode for use with FaderMate, right click

in the volume envelope lane for the track in question and choose menu option Envelope 

defaults > Volume envelope: fader scaling as shown in Figure 4.3.1

Figure 4.3.1 – Setting Volume Envelope Scaling Mode

NOTE: The volume envelope scaling setting only applies to a single track. It is 
necessary to perform this step for every track which will interact with FaderMate.



5 Automation Modes
Reaper offers several modes in which automation envelopes can operate.

To see the full list of modes which can be applied to a particular envelope (along with a 
short description of what they do), right click in the area underneath the envelope title to 
access the envelope menu as shown in Figure 5.1.

 

Figure 5.1 – Envelope Menu

Options for the available automation modes are indicated by the dashed red box.

The modes of particular interest when using FaderMate are as follows:

• Read. An envelope that has already been recorded will control the physical fader 
when the project is played back. Although you will be able to stop the physical fader
from moving along with the envelope by touching it, any changes you make will not 
be recorded.

• Write. If you play back the project, moving the physical fader will write 
corresponding changes to the envelope. The existing state of the envelope will not 
cause the physical fader to move.

• Touch. An envelope that has already been recorded will control the physical fader 
when the project is played back. If you touch the physical fader, your moves will 
override the existing envelope and write the changes back. When you let go of the 
physical fader, its movements will revert back to following the existing envelope 
points.



6 Synchronising With Other Applications
It is possible to synchronise Reaper’s playback in time using various different methods. 
However, this section only covers the use of MIDI Timecode (MTC). 

For more details about MTC, refer to: https://en.wikipedia.org/wiki/MIDI_timecode. 

Timecode synchronisation can be particularly useful in several cases:

• You are using a different DAW package, would like to do an ‘Out of the Box’ mix but 
would like to keep your automation data in a separate project (to avoid having 
‘empty’ tracks in your project)

• Your preferred DAW does not allow enough 8 channel HUI banks to support your 
automation requirements (e.g. Pro Tools only allows 32 channels of HUI-based 
automation) but you have 2 FaderMate MCUs and 48 moving faders installed in 
your console

• You would like to use something other than a DAW to store your audio (e.g. a tape 
or ADAT machine) but you still want to take advantage of the automation system.

NOTE: Reaper for Windows will not allow playback to start unless an audio interface

is connected to your computer. Therefore, even if you are only using Reaper as a 

means of storing/recalling automation data, it is necessary to make sure that an 

unused ASIO audio device is available so that Reaper will let you play your project.

6.1 MIDI Considerations
If you wish to synchronise playback of your Reaper project with another MTC-compatible 
device, you will require a spare MIDI output (if Reaper will be the master) or input (if 
Reaper will be the slave). Note that the extra input or output is an additional requirement 
over and above the requirements for connecting FaderMate.

By default, MIDI inputs and outputs are disable in Reaper unless you proactively enable 
them. 

NOTE: The MIDI inputs and outputs used for the FaderMate automation data itself 
do not need to be enabled. In fact, if you enable the FaderMate inputs/outputs using
the following procedure, FaderMate will not work. Only perform the procedures here
for MIDI inputs/outputs which will be used to pass MTC data. MIDI inputs and 
outputs used by FaderMate must be left in the ‘disabled’ state.

To modify the settings for a MIDI input or output, select menu item Options > Preferences
and then navigate to Audio > MIDI Devices as shown in Figure 6.1.1.

https://en.wikipedia.org/wiki/MIDI_timecode


Figure 6.1.1 – Accessing MIDI Device Settings

To enable a MIDI input (in order to make Reaper the MTC slave), right-click on the input in 
the MIDI inputs to make available pane and select Enable input as shown in Figure 6.1.2.

Figure 6.1.2 – Enabling a MIDI Input

To enable a MIDI output (in order to make Reaper the MTC master), right-click on the 
output in the MIDI outputs to make available pane and select Enable output as shown in 
Figure 6.1.3.



Figure 6.1.3 – Enabling a MIDI Output

Click OK to apply the new settings.

6.2 Reaper as Master
In order to use Reaper as your MTC master, it is necessary to insert a timecode generator 
track by selecting menu item Insert > SMPTE/LTC/MTC Timecode Generator as shown 
in Figure 6.2.1.



Figure 6.2.1 – Adding a Timecode Generator Track

You must ensure that the track is routed appropriately in order to get the timecode to the 
MTC slaves in your system.

In order to modify the timecode generator properties, click the ‘i’ information icon above 
the track as shown in Figure 6.2.2.

Figure 6.2.2 – Launching Timecode Generator Properties

This will launch the Media Item Properties window in which the timecode generator can be 
tweaked as necessary.

6.3 Reaper as Slave
If you would like to synchronise Reaper to an MTC master (e.g. a different DAW), you 
must configure the synchronisation settings. To do this select menu item Options > 



External Timecode Synchronization > Synchronization settings as illustrated in Figure
6.2.1.

Figure 6.2.1 – Launching Sync Settings



This will launch the settings window shown in Figure 6.2.2.

Figure 6.2.2 –  Sync Settings Window

In order to use MTC for synchronisation, the Use input dropdown must be set to MTC: All 

inputs. This will cause Reaper to listen for valid timecode signals on all available enabled 

MIDI inputs.

Configure the appropriate settings and then ensure that the “Enable synchronization to 

timecode” check box (indicated by the red arrow) is checked.
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